Automation adds row instead of updating existing row


I have set up a form to allow users to update customer information in the Customers table:


When the user clicks 'Update Details' I have created an Automation using 'Update or insert rows':

I haven't populated any Run Options.

The problem is that it is adding a new row each time rather than updating the existing row with the matching CustomerID.

Please let me know where I'm going wrong.


I'm having the same issue. It's almost as if the the match row logic is not able to find the row in the table and thus entering a new row. Does the match row function work correction on honeycode? In my case I am on an edit screen that shows the data of the row just fine.


Please help... :pray:

Hi @Matt_BicycleBook & @Shaf-a57f (welcome to the community!), your automation should be relatively straightforward and what you have should be working. Curious, could you try deleting the automation and creating a new one with the same configuration?

Here's what I have and how it should work...
2020-07-09_15-49-31 (1)

Let me know!

1 Like

@Shaf-a57f - i notice that your Is in Backlog column: field is set to =[ID] while the top of your screen shot it has '=[UPDATED BY]. There shouldn't be a mismatch, which is why I'd like to see if this happens if you create a new automation.

Thanks for your response @aj . What I'm doing is, when the user clicks a Done button at the bottom of my page, I grab their $[SYS_USER ] and write to an UPDATED BY column in the Backlog table. I'm trying to capture who updated that particular data row in by Backlog table. I am using the value shown in by field =$[Item_ID] on my page and looking for this value in the ID column in my Backlog table to find the row that needs to be updated.

I deleted the full automation, and re-created from scratch and it continues to create new rows in my Backlog table and putting the $[SYS_USER] value in UPDATED BY cell or the new rows. I also noticed there is a warning when I hover over my =$[Item_ID] formula, but that might be a known product issue?

Here are some screen captures..
(I have 5 screen grabs, but this forum will not let me upload more than one screen capture, thus the shared folder link below)

@Shaf-a57f thanks for the additional info. Let me see if I can replicate the issue on my end using the same structure you have provided. Will be in touch soon!

@aj Thank you for your active assistance. I'll wait to hear back from you.

Hi again @Shaf-a57f - have you tried updating your Item_ID data cell to a variable type instead of shared? If not, please try that and let me know what happens.

Also, any way you could share your table(s) setup? This could help diagnose as well. (please exclude any sensitive table data)

Hi @aj, I will try deleting and re-creating the automation a bit later - having some trouble with the platform at the moment. Getting a few error messages, not sure if it's just me or a wider issue.

Thanks for your support thus far.


Hello @aj,

I've deleted the automation and recreated it from scratch. Unfortunately I'm getting the same issue!

I was wondering if it's a formatting issue, whereby the format of the data cell and the corresponding table column don't match, so I changed them both to number and still no joy.

Any ideas?


Hi @aj I changed the Item_ID data cell to a variable type instead of shared. This did not work, still created a new row with ERROR value. See Screen1 and Screen2 in the linked shared folder. Additionally, Screen2 shows you my table. I hope this is what you were asking for.

Hi @Matt_BicycleBook, thanks for trying and sorry to hear you are still having difficulties. Here's my setup and it's working, so take a look and see what differences you might have:

Notice any differences between my setup and what you have?

1 Like

Thanks @Shaf-a57f for the addt'l info & for your patience. See my post above to @Matt_BicycleBook in case that helps. In any event, I'm going to raise this up with the product team to see if we can collectively figure out what's going on.

@aj my edit screen (auto generated by honeycode wizard) works fine with my Input Fields set to shared. I have even tried updating with a hardcoded value using formula to find the row that needs to be updated. I also exposed the field as uneditable on the screen (I don't want anyone to manually update this, only automation should update this). I am still getting a new row created and not in the same row. I think there might be a product bug.

Hi @Shaf-a57f yep that's the way i'm treating it at this point as well. Stay tuned.


Based on the information so far, it looks like the row is not being updated since there is a mismatch in the content format between the content in the column and the value being compared. Let's say your table has:

ID User Comment
Test 999 abc testing

Now if you create an app screen where the list shows these rows and then you click on it, the app is passing the rowlink of this row to the detail page so you can extract any part of the row. This is set as $[InputRow] by default.

Now when you use the add or update automation, you can either create a rowlink column within this table using =thisrow() formula and compare it against that (Recommend setting it as the default formula of the column rather than the cell as shown)

Screen Shot 2020-07-14 at 2.29.29 PM


Use dereferencing to compare the condition as text rather than rowlink. To test as text, you can use the following syntax:

=$[InputRow][ColName] where ColName is your unique id for the row.

Screen Shot 2020-07-14 at 2.32.50 PM

Please let me know if you continue experiencing issues.

Hi @aj, thanks so much for taking the time to replicate the form and going through the process step-by-step. It looked like I had the right things ticked but I just deleted everything and built it again from scratch - and it now works!

Much appreciated, thanks for your help.


1 Like

That's excellent news @Matt_BicycleBook! And happy to help. Hope the rest of the building is a bit smoother, but you know where to find us if not. :slight_smile:

@Kamran your suggestion was SPOT ON! This clearly solved my problem. You guys ROCK! Forward and Onward! I am eager to see where honeycode feature can take us users. Can't wait to provide user feedback and participation (if you all need that).

A feature that could rock honeycode further would be charting features and some level of graphics / logo and colors on page.

1 Like

Great to hear @Shaf-a57f and thanks for the follow up! Also, we appreciate the feature request as well as the offer for feedback. We're still working through all of that but will take note of your post for any future needs! Happy Honeycoding :slight_smile: