Error when executing invoke_screen_automation to overwrite row


I built an app including a screen used to select a table row and overwrite one column in it. When testing my app in the Web interface, it works perfectly.

When I attempt to overwrite the same row using invoke_screen_automation in a python script, I get the following error:

botocore.errorfactory.AutomationExecutionException: An error occurred (AutomationExecutionException) when calling the InvokeScreenAutomation operation: Automation failed to run because one of the formulas could not be resolved to a sheet cell

Furthermore, an error message pops up in the app builder: Data binding error: Cannot resolve a pill to cell.

Because I am querying for data in the table and printing it out for debugging, I am confident that I am sending the correct Row value to invoke_screen_automation. I have checked and double-checked by app, workbook, screen, and automation IDs. How can I diagnose this error? Are there any known related bugs?


Hi @Iris-7c51, welcome to the community and sorry to hear of these difficulties! I'd like to request that you could share some screen shots of your app configure (screen, data cells, etc.) if possible, so that we can better diagnose what might be happening here. Please be careful not to send any personal/company related data in these screen shots.

Also, just a point of clarity, you had mentioned about the botocore error in the python script as well as an additional error in app builder. Does this app builder error happen when you run the automation in the web interface? Or does it actually pop up when you run the python script?

Lastly, you may want to look for any editable shared data cells in the app screen where your automation button exists and confirm that they are variables (not shared). If they're shared, this could very well be an issue.

Let us know!

Thanks, aj. I am adding some screenshots.

Also, the app builder error happens ONLY when I run the python script. Running the automation in the web interface is successful with no errors.

Hi @Iris-7c51, some follow ups if you don't mind:

  • could you also share the data types of $[action_ts} and for $[row]?

  • just want to confirm that what you have blurred out is indeed a valid destination?

  • could you also get a diagnostic id by going through the report an issue process?

These situations can be a bit difficult to troubleshoot over chat, so thank you for your continued patience as we work through it.

Hi @Iris-7c51,

Thanks for sharing more info with us in your issue report -

Just updating this post to share the solution that worked, in case it helps others on the forum as well.

Solution: when using the python SDK, the "rowId" field will need to be added to the input. So for example:

                variables={"Row": {"rawValue": row}, "action_ts": {"rawValue": date_str}})
                rowId=<same rowId being used for Row variable>

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.