How to import a large number

I'm trying to create table importing data from a csv file. I have an ID which is a large number, this an example:


but when I import the data I see in the column as 192891E+18 and the value is 1928913000003370000

The last four digits are converted as 0 values.

I applied as Text plain format but does not work.
How Can I fix it?

1 Like

Hi @anon24200216 upon import you're losing some precision as this field is being detected as number (correctly), but is bigger than 15 digits. Unfortunately, applying the plain text format after the precision has been lost will not bring it back. There are a couple of ways I could think of working around this: 1/ In your CSV, add an alphabet to this column so upon import Honeycode treats it as plain text rather than number. or 2/ set the format to plain text and then copy and paste the data from CSV. Either of these options should work. I'll also make a note for my colleagues working on this area to improve on this experience.

1 Like

Hi @RajeshGoli,

 The first option is ok, I've added a letter before the code and import correctly.
 The second option only work if I copy one by one.

Thanks for your help.

This topic was automatically closed after 14 days. New replies are no longer allowed.