Long string going to Webhook

Hi there, I am having an issue when trying to send data to Zapier with a webhook. The data displays fine on Honeycode, but when the data is received on Zapier, it shows a long string. I believe the issue is that it is a picklist. Does anyone know how to get it to pull data properly?

Hi @Max,

Welcome to the community! :honeybee:

Thanks for you post here :slight_smile: I'm happy to help you out.

The reason why you're seeing a row ID string is because your automation is passing in the entire rowlink (which includes all columns of data in that row).

If you'd like to only pass in data of a particular column, you would specify that column in the formula in the "Payload value" field. For example, if you'd like to write "Football", specify the name of the column in the rowlink where that data is located.

The formulas would look like this:
=$[Organization][Name of desired column]
=$[Sport][Name of desired column]

This will then take the data of that particular column in the rowlink to send to the webhook.

Let me know if this helps clarify! :smiley:

1 Like

Ah that makes more sense! Thank you!

I tried the =$[Organization][Name] but now I get an #VALUE! error.

The column in my Organizations table for the value I would like to get is [Name].

Same error with Sport. Thanks so much for your help!

Hi @Max,

Great, I'm glad that helps :slight_smile:

For the #VALUE! error; that would return if no particular rowlink is specified in the input field yet.

In run-time, the desired value would be sent to the webhook by the automation in the button, if a rowlink is selected and the column name in the formula is correct.

A way to solve this would be to wrap the formula with an IFERROR() function that would write a default value is nothing is selected. For example, I created an app similar to yours, and it writes "No item selected" if a user were to click the button without selecting a rowlink first.

This is how it looks in Builder:

Let me know if that helps! :honey_pot:

Thanks! I'm having trouble understanding why there is an error though even if an item is selected. Here, it "School of Cool".

Here is what the table looks like:

Hi @Max,

Thanks for your quick replies here! :slight_smile:

The reason why you're seeing this in Builder is that the variables in the formulas is are input variables ($[Organization] and $[Sport] are both input variables). Input variables do not have a value until there is value selected or entered during run-time.

The IFERROR() solution I provided above would resolve the error you're seeing in Builder as well.

In the app during run-time, if you were to select the rowlink and click on the button, it would write the data from the specified column in that rowlink as it has the input needed to pull the data.

Here's a screenshot of selecting the rowlink during run-time:

I hope that makes sense!

I'll note that we've seen similar experiences and received feedback on how formulas are evaluated in Builder, so I'll share your experience with our team as well.

Let us know if you have any further thoughts or questions around this. :honeybee:

Got it. However, my button to send to external source is in the details page, not in a form. Does that make a difference? So, it would already have a value because a form was filled in a previous step.

The details page is uneditable, says "School of Cool" but the data to zap says "No Item Selected"

Hi @Max,

Thanks for sharing those additional details! It seems like you're very close and may just need to enter the correct name of the row on your screen. If you're on a details screen, your desired row might set up as the $[InputRow] variable.

You can check this by clicking on the block where the fields are and checking the source in the properties window:

If that be the case, your formulas may look something like this:

I hope this helps guide you in the right direction! Let us know. :slight_smile:

Got it! Thank you for your patience and quick responses while I am learning Honeycode! I did $[InputRow][Organization][Name] and that worked. That does make more sense now seeing how the structure is in Honeycode.

Look forward to finishing my app and implementing it in the company :slightly_smiling_face:

1 Like

Hi @Max,

Great! I'm happy you got it working :slight_smile:

And of course, we're always happy to help :honey_pot: :honeybee:

Feel free to reach out to us again if you have any other questions while you build.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.