Setting Rowlinks and Picklists from Zapier

Hello! I was wondering for Setting Rowlinks and Picklists from Zapier - is there a limit on the functionality? It worked great for me when it was a string and the table that had the picklist only had < 10 rows.

However, I have a large table that I need to find the picklist value for and it only passed in the actual value. The value is a number and the table has over 1,000 rows, if that helps. Thank you!

It would be great to have this rather than FINDLASTROW(), which works in this case.

Hi @Max :slight_smile: :honeybee:

Once you set up a picklist in an app, for the webhook automation, you would pass in the selected picklist value and the column from that row which you'd like to display.

This is how it would look:

I set up an editable data cell that's a picklist to a table of grocery items:

For the automation on the button, it sends the column of the picklist variable which has the value I'd like to display (in this case, the name of the item):

And this is what is sent in the zap:

Regardless of the number of rows links in that picklist, this would send your specified value of the selected row in the zap.

Hope that helps, and let us know if you have any other questions around this! :honey_pot:

Hi @Alyssa,

I mean the other way around. The update mentioned that we can type in the string in Zapier and it will find the rowlink automatically. However, that isn't happening. The value is entered as a string.

In Zapier, I am using the "Add A New Row to Honeycode" action and typing in the string. However, when it goes through, the cell is a string rather than the row link. In my table, it is set up as a row link.


Hi @Max, got it, thanks for that clarity -

If you send a string from a zap to a Honeycode table, it will be formatted as a rowlink as long the column is formatted as a rowlink and it matches an existing rowlink.

I just tested this, and it is working as expected (I sent string data from a zap to a column formatted as a rowlink. Since the string matches an existing rowlink, it became a rowlink in the table):

From what you've described, it sounds like you've checked both of those criteria. Perhaps you could double-check that the rowlink is set to the correct table. If it's still not working as expected, could you submit this to us in an issue report, so we can take a look at the logs? (Send the zap, and then submit the report to us). Provide any other helpful screenshots or info as well.

Thank you. I have double checked and I believe I have everything set up. I have reported the issue.

Here is my column setup:

Here is how I pass it in Zapier:

Here is the result when it comes in Zapier.

Please let me know if I am missing something. Thank you!

Moderator note: Edited out personal information from image.

Hi @Max, thanks for submitting your issue report! Our team will take a look and see if there are any bugs.

From looking at your screenshots here, I can help you out if this is simply a set-up tweak:

For the column in your second screenshot which contains "1929", "1930", "1931", is that column formatted as a rowlink to a table which contains each of those rows? You'll want to have another table where the first column contains the data "1930", "1931", etc. If those rows do not exist yet, they will appear only as strings in Honeycode.

Hi @Alyssa, yes it is set up where that column is a row link and the table in the first screenshot's first column contains 1930, 1931, etc.

Hi @Max :honeybee:

Based on the findings in the logs, the reason why those particular zaps did not result in the string converting to a rowlink is because there was no value in the first column of the table that matches the string that came in.

Would you be able to provide a screenshot of the table that is rowlinked and another screenshot of how the rowlink is set up on the column where the zap is coming in?