Time based automation not running

We have just discovered that one of our time-based automations has not run since about 4:00 am UTC today, although there are records in the table that should have triggered it since then. I've tried moving the timestamp on a row to a future time and the automation still has not triggered. Nothing was changed on this automation. Anyone have any idea what might be going on?

As an update, I found that there was a row that had something strange going on. When I filtered the column, the filter showed that row as having a time and date value, but when that row was displayed in the table it appeared blank. I tried clearing out the value in that cell but it hasn't solved the problem.

Hi @Michael_W_SCR ,

Thanks for reaching out and hope you are doing well.

Would you please open an issue report while you are inside the workbook. It will provide us with more diagnostics and will help us troubleshoot.

Thanks for looking at this. As a work-around we have changed the automation to be triggered when the column changes. It is not what we want but is working well enough until we can get it resolved.

I changed the automation back to be triggered by time, set a row with a time in the future and waited until a couple of minutes after that time had passed, then submitted an issue report. Hopefully that will provide some useful troubleshooting information. I have changed the automation to be triggered on the column change again after submitting the issue report. (I just wanted to share that in case that has any impact on what you see in the issue report.)

Hi @Michael_W_SCR ,

Thanks for submitting the issue report and glad that you have found a workaround.

I'll be working with our engineers to dig deeper into the issue.

Any news on this? We seem to be having some issues with some other date-based automations as well.

Hi @Michael_W_SCR,

My apologies for the delay and any inconvenience this may be causing. I checked in with our engineers, and they are still working on it.

To help us look into this further:

  • Is there any more information you can provide on the steps you took that resulted in the issue? A screenshot or video with sensitive information redacted would be helpful.
  • How far into the future are your timers being set? We want to mention that the lowest granularity we can process timer automations in one minute.

Thank you,


Sorry, didn't see your questions before. We have an outside system that uses the API to add records into a Honeycode row. When we add records, we set a field on a master record to 5 minutes in the future so that some calculations on that master record can be updated.

I will say that before I reported this issue, we were able to set the field to 20 seconds into the future and it would work consistently.

(We don't want to move those calculations into formulas in a field because they involve the sum of a field in a filter statement and it creates issues to have those kind of formulas in a field.)

This topic was automatically closed after 19 hours. New replies are no longer allowed.

Thanks for following up, @Michael_W_SCR.

I've shared your details with our engineers. Are you still encountering any issues?



I hadn't checked until just now, but it does seem to be working now.

Thanks for letting us know, @Michael_W_SCR. Please feel free to follow up if you encounter the issue again.