Delete Buttons troubleshooting

Hi again,

I'm continuing learning from this template, while building my own.

On the Contact Detail screen, there's a Delete button which supposed to delete a data row. Is this correct?

When I tried to delete from the View app screen, everytime I got a message "Sorry. We are unable to complete that action. Please try again."

Then, I notice that when I got back to the build screen, there's a message popping up that said, "Cannot find the row to delete."

I tried to figure out the automation of the Delete button. But, probably because I'm still a beginner, it seems correct to me. And I don't know how to modify it anyway. :grin:

Can you help?


1 Like

Never mind. I figured it out. :smiley:

Turns out the Block Data source of the button must be set to the same $[Inputrow] variable.

Did I erase that source accidentally or was it like that from the template?

Hey there! I'm experiencing a similar issue, but I'm not entirely sure how you fixed it.

Creating a new Delete button within the same Block seems to work. But when I move the button to a new block/segment, it breaks and I receive the "Cannot find the row to delete" error message. :weary:

Sorted out what you meant by "Block Data source" and attached a picture for anyone having difficulty with Delete buttons. Thank you! :+1:

1 Like

Sorry for not posting a picture before. I wasn't sure how to post a pic. Glad you found the solution and even post a pic. :smile: :pray:t3:

1 Like