Desktop App Not Opening

My desktop app is not opening in my browser google chrome. I've tried the following things and the app is just not opening on the browser.

  1. I tried logging into the app and the browser keeps getting refreshed in a loop.
  2. I tried clearing the cache, cookies and other browsing data. Result : Same problem persists.
  3. I tried a different browser.
  4. I tried opening the desktop app from the builder - view app button.

PS. The app is working fine in the mobile aws app.

No luck with desktop app.
Please help.

Hi @Sankalp I'm sorry to hear you are experiencing difficulties. Do you have the most up to date Chrome browser? If you don't, could you try updating Chrome and see if you can replicate again. If you are still experiencing the issue, could you log into your account > go to app builder where you attempted to click on the 'view app' button > click on the '?' icon on the left panel > 'Report an issue'. This will provide our team with diagnostic information to help further troubleshoot this.

If you do report the issue via the steps above please also include any further details in the note. For example, when you say you tried logging into the app, did you copy and paste the app url into your browser?


Hi Matt,
Thanks for your suggestion.
I updated chrome and tried all the different methods mentioned above also however no change of luck. Still unable to use the desktop app.

I have created a diagnostic report for the issue as suggested by you and also tagged you in it. Hopefully this will help you guys in figuring out the issue.

Let me know if i can be of any further assistance.


So the app is now suddenly opening on its own on the desktop. Perhaps upgrading chrome must've had the effect which kicked in with a bit of a delay.

The browser first went into a login spiral and then just opened the desktop app page.
PS: I opened through the view app button this time.

Thanks for your help

Glad to hear you are able to view the app now @Sankalp and thanks for the update here!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.