Flag Controls With Errors

It would be nice if controls could be flagged or highlighted in the editor if there is an error in any of the fields in the Data, Display, or Actions tabs. Maybe something like a read box around them? Or a list of the controls even would be great. Sometime, when I delete a delete a column, I have to spend a large amount of time hunting for [#REF] errors, which is a pain.


Hi @Luke, thanks for your request! :honeybee:

That's a good note. In Builder, you can easily see data cells that are not evaluating correctly / returning an error, however I can see how objects with automations are not as apparent if they have an error (such as buttons).

I'll pass along the feature request to our team for a visual indicator on objects in Builder that contain formula errors.

Also, for a tip regarding to your last note on deleting columns, you are able to move columns rather than delete (There's a tab that appears over the column that you can click and drag to move the column). That way you don't break any formulas, and you won't have to rewrite them to associate to a new column. :slight_smile: :honey_pot:

1 Like

Hi @Luke , i'm with you on this.

I had just, only just, encountered an issue with my app which caused me a bit of confusion. lol...

I was unable to click on the button in-app and Honeycode would state in a redbox that the operation failed and i could retry. It, however, would not tell me what was wrong. I do need that! lol... sometimes i'm writing about 18 rows and if one destination field is missing, i could easily skip over that visually and think nothings off!

Have a look at the image now and i'll explain how I arrived at this state (what i did wrong, supposedly! LOL)

In the screenie above, i'm writing to specific columns in my table 'Ledger", however "Transaction type" was not written to a specific column called "Transaction type" and instead lay a "Select column" option. That was causing the error! urgh!

PS: Also noticed that the nice Green Dots weren't showing. That's exactly what i use to quickly determine IF the statement is correct/wrong. So usefuL!!!!!!!!

So i'll list out what i had been experiencing but never reported because I figured it was teething pains (or me just being weird lol) and I'm ok to work around it.

  • Ledger[Transaction type] was somehow renamed to something else, a dollar figure (for example: 110.3) i was keying in to one of the fields (not headers) - something caused my focused cell to move to the header. It took a while to find this and when i did facepalm... AND SO i fixed it. Renamed it back to "Transaction type"

  • This issue happened after i fixed it. The FILTER() command in another table showed that it updated to Ledger[110.3] but didnt' change when the above-stated rename happened. One-way street there?
    Another screenie for a page that didn't update.

  • something : when a new column is added, the new column appears AND the selected cell jumps out of the new column. Here's what I was expecting to do. Right-click, select new column, select to the Right, start keying in the name of the new column. Here's what is happening now >>> fast forward.... select to the Right, click left on the keyboard to get to New column OR mouse-click on header of new column, start keying in the name of the new column.

  • also on something : when editing the header of a table, if i use the example of excel column naming, A, B, C, D, E... --> When I change the header in column A, and hit TAB or hit RIGHT arrow on the keyboard, it jumps me to column C. I wish it would bring me to B, so I can edit B's column header.

ok! that's my report. sorry for the lengthy report but it's the only way to get info across :slight_smile: better more than less imho for product development.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.