Batch Delete Table Rows Request Not Getting Processed

Dear Team,

I am trying to delete all rows in a table with 6000 rows except the headers.

I have tried three ways all unsuccessful

  1. Tried manually selecting all rows and selecting "Delete Rows" manually. It gave an error message "Sorry your request could not be processed"

  2. Tried setting automation. Again waited for a long time but the automation did not run

  3. Tried using Batch Delete Table Rows Request using API but it is giving the below error "An error occurred (RequestTimeoutException) when calling the BatchDeleteTableRows operation (reached max retries: 4): Request did not complete within 28000 milliseconds and is still processing".

Is there any way I can delete data from this table?


Hi @Nira-c595 ,

Thanks for reaching out.

I'll appreciate if you can submit an issue report when you get the error while deleting these rows.

Issue report will provide us with more diagnostics.

Hi @Pankaj thank you for the quick revert. I could make it work by deleting 1000 rows at a time manually. Thanks for the help. But now I am facing another problem, I am not able to delete specific workbooks. I have already raised the issue report for the same.

hi @Nira-c595 ,

Thank you for submitting the issue report, I am getting in touch with our engineers. I'll reach out to you as soon as I hear anything back from them.

Thanks for your patience.

This topic was automatically closed after 21 hours. New replies are no longer allowed.